Konfigurationsanleitung

Der nachfolgende Artikel zeigt Ihnen diverse Konfigurationsteile für die Konfiguration Ihres SIP-Trunks mit Cisco-Telefonanlagen.

 

Falls Sie noch kein Kunden sind, testen sie GRATIS und UNVERBINDLICH unseren VOIP-Trunk für 4 Wochen und überzeugen Sie sich vom Mehrwert. Sie erhalten direkt nach der Anmeldung Ihre persönlichen Zugangsdaten per E-Mail.

Cisco Fragmente

Quelle: Kunden
Geändert: 16.10.2018
Hersteller: Cisco
Bestimmt für:
Modell Hersteller Firmware Datum Getestet von
Cisco Voice Gateway 2911 Cisco 15.5 - -

So verwenden Sie diese Anleitung:

Diese Anleitung verweist auf Ihre persönlichen Zugangsdaten, die Sie wie abgebildet, in einer Email von uns erhalten haben. Dabei gilt:

  • Grün abgebildete Werte sind individuell
  • Blau angezeigte Werte sind für alle Kunden identisch

Bitte beachten Sie, dass die Rufnummer(n) in den meisten Fällen im Format "E.164 ohne Präfix" z.B. "49305566123" angegeben werden/wird.

Orange bedeutet, dass die Angabe der Werte nur in besonderen Fällen nötig ist (siehe Erläuterungen).

Wichtiger Hinweis:

Diese Anleitung bezieht sich auf die Standardeinstellungen unseres VoIP-Trunks. Änderungen an den Einstellungen des Trunks im Webportal können entsprechende Anpassungen am Gerät nötig machen.

Auszug aus: Email mit den Zugangsdaten
Rufnummer(n)
SIP-Domain/Realm
SIP-Account
SIP-Passwort
trunking.equada.net:5060
5060

1. Über diese Anleitung

1.1 Wichtiger Hinweis

Diese Anleitung enthält vereinzelte Fragmente der Anbindung einer Cisco Telefonanlage an unserem Trunk. Die Fragmente bestehen zum Größtenteil aus nicht von uns verifizierten Kundeninformationen.

2. Fragmente

2.1 Beispielkonfiguration eines Cisco Voice Gateway 2911 und Call Manager 11.5

Nach Kundenangabe fehlt hierbei nur ein weiterer Eintrag in den SIP Profiles, da ansonsten Anrufe beim Angerufenen immer weiterklingeln, auch wenn aufgelegt wurde.

Current configuration : 13575 bytes
Last configuration change at 13:58:28 CEST Tue Sep 12 2017 by admin
version 15.5
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service internal
service sequence-numbers
hostname  Hostname
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.155-3.M3.bin
boot-end-marker
card type e1 0 0
logging queue-limit 10000
logging buffered 30000000
logging rate-limit 10000
enable secret 4 aM3G6Nhqh/YBgdfsgdGdfjhSD0Vgf/UZU.pzhfg3ozu65Qyh63dDsC
no aaa new-model
ethernet lmi ce
clock timezone CET 1 0
clock summer-time CEST recurring
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
ip domain name your domain
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx
ip cef
no ipv6 cef
multilink bundle-name authenticated
isdn switch-type primary-net5
crypto pki trustpoint TP-self-signed-1234567890
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1234567890
revocation-check none
rsakeypair TP-self-signed-1234567890
crypto pki certificate chain TP-self-signed-1234567890
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
........ ........ ........ ........ ........ ........ ........ ........
CF798A7F 2A46AA7D 4490BD39 070BCF
quit
voice-card 0
voice call send-alert
voice call convert-discpi-to-prog
voice rtp send-recv
voice service pots
fax rate disable
voice service voip
ip address trusted list
ipv4 xxx.xxx.xxx.xxx
ipv4 xxx.xxx.xxx.xxx
ipv4 46.182.249.32 255.255.255.240
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol none
h323
h225 signal overlap
sip
registrar server expires max 600 min 60
voice class uri 10 sip
voice class codec 10
codec preference 1 clear-channel
codec preference 2 g711ulaw
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
voice class h323 1
h225 timeout tcp establish 3
voice class sip-profiles 1
request INVITE sip-header To modify "<sip:\+(.*)@.*>" "<sip:\1@SIP-Domain/Realm>"
request INVITE sip-header P-Preferred-Identity modify "<sip:0(.*)@.*>" "<sip:49\1@SIP-Domain/Realm>"
request INVITE sip-header From modify "<sip:0(.*)@.*>" "<sip:49\1@SIP-Domain/Realm>"
request INVITE sip-header SIP-Req-URI modify "sip:\+(.*)@" "sip:\1@"
request INVITE sip-header P-Preferred-Identity modify "sip:\+(.*)@.*>" "sip:\1@SIP-Domain/Realm>"
request INVITE sip-header From modify "<sip:anonymous@.*>" "<sip:anonymous@SIP-Domain/Realm>"
request INVITE sip-header From modify "<sip:([^(0|anonymous)].*)@.*>" "<sip:4930123456\1@SIP-Domain/Realm>"
voice class server-group 1
ipv4 xxx.xxx.xxx.xxx
ipv4 xxx.xxx.xxx.xxx
description UCMs
voice register global
default mode
system message NOTBETRIEB
max-dn 300
max-pool 58
voice register pool 1
id network Netwerkadresse mask Netzwerkmaske
voice translation-rule 21
rule 1 /^4930123456/ /+4930123456/
voice translation-profile FROM-SIP
translate called 21
license udi pid CISCO2911/K9 sn ABC123DEF
hw-module pvdm 0/0
archive
path ftp-Pfad für das Archiv
write-memory
username admin privilege 15 secret 4 aNOm3Nlqe/YBMsLDKa30Vk/UY7.bjMZkfZR3oRQyoDY
redundancy
notification-timer 120000
controller E1 0/0/0
pri-group timeslots 1-31
description OUTBOUND-PSTN
class-map match-all SCCP
match access-group name SCCP
class-map match-all RTP
match access-group name RTP
policy-map Voice
class RTP
set dscp ef
class SCCP
set dscp cs3
interface Embedded-Service-Engine0/0
no ip address
shutdown
interface GigabitEthernet0/0
description UPLINK-TO-LAN
ip address xxx.xxx.xxx.xxx netmask
duplex auto
speed auto
service-policy input Voice
service-policy output Voice
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 2000
isdn incoming-voice voice
isdn number called enbloc 2
no cdp enable
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
ip access-list extended RTP
permit udp any range 16384 32767 any
permit udp any any range 16384 32767
ip access-list extended SCCP
permit tcp any eq 2000 any
permit tcp any any eq 2000
logging trap debugging
snmp-server community public RO
control-plane
voice-port 0/0/0:15
cptone DE
description PSTN
bearer-cap Speech
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
mgcp profile default
dspfarm profile 1 mtp
codec pass-through
codec g711alaw
maximum sessions software 100
associate application CUBE
dial-peer voice 10 pots
description OUTBOUND-PSTN-1
translation-profile outgoing STRIP-LEADING-0
preference 1
shutdown
destination-pattern 0.
progress_ind alert enable 8
fax rate disable
direct-inward-dial
port 0/0/0:15
dial-peer voice 100 voip
description Beschreibung
preference 1
shutdown
destination-pattern 6103T
session target ipv4: 10.234.6.240
voice-class h323 1
dtmf-relay h245-alphanumeric
codec g711ulaw
fax rate disable
no vad
dial-peer voice 110 voip
description Beschreibung
preference 2
shutdown
destination-pattern 6103T
session target ipv4: xxx.xxx.xxx.xxx
voice-class h323 1
dtmf-relay h245-alphanumeric
codec g711ulaw
fax rate disable
no vad
dial-peer voice 200 voip
description SIP-TO-UCM1
huntstop
preference 2
destination-pattern +4930123456.%
session protocol sipv2
session server-group 1
voice-class codec 1
no voice-class sip privacy-policy passthru
voice-class sip options-ping 60
dtmf-relay h245-alphanumeric
fax rate disable
no vad
dial-peer voice 20 voip
description SIP-TO-PSTN
destination-pattern +.%
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip asserted-id ppi
voice-class sip profiles 1
dtmf-relay rtp-nte
fax rate disable
dial-peer voice 21 voip
description SIP-FROM-PSTN
translation-profile incoming FROM-SIP
incoming called-number 4940654321.
voice-class codec 1
no voice-class sip asserted-id
dial-peer voice 25 voip
description SIP-FROM-PSTN
translation-profile incoming FROM-SIP
session protocol sipv2
session target sip-server
incoming called-number 4930123456.%
voice-class codec 1
no voice-class sip asserted-id
dtmf-relay rtp-nte
dtmf-interworking standard
fax rate disable
dial-peer voice 201 voip
description Beschreibung
huntstop
preference 1
destination-pattern +4940654321.%
session protocol sipv2
session server-group 1
voice-class codec 1
no voice-class sip privacy-policy passthru
voice-class sip options-ping 60
dtmf-relay h245-alphanumeric
fax rate disable
no vad
dial-peer voice 202 voip
description Beschreibung
huntstop
preference 1
destination-pattern +4969111000.%
session protocol sipv2
session server-group 1
voice-class codec 1
no voice-class sip privacy-policy passthru
voice-class sip options-ping 60
dtmf-relay h245-alphanumeric
fax rate disable
no vad
dial-peer voice 23 voip
description SIP-FROM-PSTN
translation-profile incoming FROM-SIP
incoming called-number 4969111000.%
voice-class codec 1
no voice-class sip asserted-id
dial-peer voice 22 voip
description SIP-TO-PSTN
destination-pattern 0.%
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip asserted-id ppi
voice-class sip profiles 1
dtmf-relay rtp-nte
fax rate disable
dial-peer voice 120 voip
description Beschreibung
translation-profile outgoing FROM-EXTERNAL
preference 1
destination-pattern 21T
session protocol sipv2
session target ipv4:xxx.xxx.xxx.xxx
voice-class codec 1
voice-class h323 1
dtmf-relay h245-alphanumeric
fax rate disable
no vad
dial-peer voice 130 voip
description Beschreibung
translation-profile outgoing FROM-EXTERNAL
preference 2
destination-pattern 21T
session protocol sipv2
session target ipv4:xxx.xxx.xxx.xxx
voice-class codec 1
voice-class h323 1
dtmf-relay h245-alphanumeric
fax rate disable
no vad
dial-peer voice 203 voip
num-exp 4930123456 21119
sip-ua
credentials username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
authentication username SIP-Account password 7 SIP-Passwort realm trunking.equada.net:5060
authentication username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
no remote-party-id
registrar dns:SIP-Domain/Realm expires 3600
sip-server dns:SIP-Domain/Realm
gatekeeper
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
scheduler allocate 20000 1000
ntp peer xxx.xxx.xxx.xxx
ntp peer xxx.xxx.xxx.xxx
end

2.2 Nicht funktionierende Config der SIP-ua

Kunde hat damit keine Antwort von unserem Server erhalten:

credentials number Rufnummer ohne 49 username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
credentials number Rufnummer mit +49 username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
credentials number Rufnummer mit 49 username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
authentication username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
registrar dns:SIP-Domain/Realm expires 60

2.3 Cisco Cube

Für den Cisco Cube ist es unseren Informationen nach nicht ohne weiteres möglich und nicht in den Standarteinstellungen vorgesehen, dass zwingend der gleiche Port für ausgehende Gespräche und die Registrierung genommen wird. Dadurch kann zu einem SIP error ; cause=500 ; text="Classification Failure" kommen.

2.4 Custom SIP-Header

voice class sip-profiles 1
request INVITE sip-header P-Asserted-Identity add "P-Asserted-Identity:sip:1111111111@sbc.sipprovider.com"
dial peer
voice-class sip profiles 1
sip-ua
authentication username SIP-Account password 7 SIP-Passwort realm SIP-Domain/Realm
registrar dns:SIP-Domain/Realm:5083 expires 60 auth-realm:SIP-Domain/Realm

Diese Anleitung ist nicht Leistungsbestandteil des Services und hat keinen Anspruch auf Vollständigkeit. Ebenfalls hat der Provider die Anleitungen regelmäßig nicht getestet/verifiziert. Eine Haftung für Schäden aus dieser Anleitung, wenn nicht zwingend vorgeschrieben (siehe AGB), wird ausgeschlossen. Der Kunde kann in Bezug auf den Service keine Ansprüche gegen den Provider herleiten.

Build: 4540 - 2018-10-17 14:47:56 +0200 (Mi, 17. Okt 2018) CO: 2018-10-17 14:48

Suche